Jump to content

Recommended Posts

  • Replies 140
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

that's an awesome game so far xD so when do you think you'll finish it ;) oh yeah... you guys should add more customization to how you start out, you don't wanna a ton of people looking exactly the

uhmm.. make the characters realistic size... please... they all look like.. dwarfs?.. lol.. and classes would be nice? :P they all look different but i cant tell which ones a assassin or wizard or s

This has been brought back online! After 10 years of downtime. https://theworld.gd-u.com/game/The World.exe

Posted Images

i cant seem to be able to downlaod .net framework 2.0 on any of my pc's can you possibably make the game not need .net framework or make it compatible with the 1.1 or an other program that works with a 64 bit pc. please and thank you btw im looking forward to be able to play this game

x64 installations no matter the OS supports a bi 32/64 environment. The launcher is compiled against .NET Framework 2.0 and is intended to run as a 32-bit executable, so you will need: http://www.microsoft.com/download/en/details.aspx?id=19 in order to get the game running(this is noted in the first post). Do not worry about it being x86, it will run just fine on x64 installations. :) Trust me on that one. I've been a fulltime x64 user for quite some time now and I can say that if you're on Vista or 7, 64bit plays quite nice with 32bit! Welcome to the BBS, by the way :)

Link to post
Share on other sites
  • 3 weeks later...
  • 2 months later...
  • 4 months later...
3 hours ago, hawthorneluke said:

I really need to find out a way to get this working on osx

 

image.png

This always makes me laugh 😂 

 

! Didn't even notice this one 😂 

image.png

Lmao!

I forget how long it's been like that on both names.

 

As for getting this to work on OSX - actually quite easy, man! Wine will run this no problem at all. In fact, even basic stock configuration will work with no issues, haha. You can give Valve's Proton a try as well. 😛 It's funny, [TheWorld] runs better in Wine than it does on Windows, because half of the time on Windows it randomly errors out. I traced the issue down to GameMaker not binding to the fmodex dll handle properly.

Link to post
Share on other sites
On 9/16/2020 at 2:21 AM, hawthorneluke said:

I really need to find out a way to get this working on osx

 

image.png

This always makes me laugh 😂 

 

! Didn't even notice this one 😂 

image.png

LOL

Link to post
Share on other sites

Just tried again with new install etc and it still just dies half way through the main menu loading (in gm, after gm itself has loaded) 😧

 

hmmm.... just looking at wine log here, and memories are starting to come back.. with others having similar problems, with the game dying as soon as it starts to try playing music...

"003c:err:dmloader:IDirectMusicLoaderImpl_SetObject : could not attach stream to file L"C:\\windows\\system32\\drivers\\gm.dls", make sure it exists"

 

hmm, but that's outputted during the gm loading, not after in the main menu loading when it crashes...

still, could be a log from when it tries to load it in, then when gm tries to play music during the menu load it explodes, pretty sure that was a problem people had before

 

hmm, manually downloading and adding the file to the dir didn't change anything, so messed about with brew and install winetricks, which has gmdls in its list of stuff to install, which I did, and now that error's gone, but it still crashes in the same place lol

Link to post
Share on other sites

hmm, seems to crash when trying to access network, of course the launcher works with its downloads, so not a general network problem

just randomly using winetricks to try and install stuff found in error log lol and got one that's taking a while.. and for some reason I've just found a "39dll.dll" in my downloads dir... more memories coming back now, pretty sure that's what I used to do the networking.. maybe 🤔

oh... that was just from the contents the game downloaded lol

still not working 🤔

ooo but now got a load of wininet errors... getting somewhere!

Link to post
Share on other sites

can't get past these errors... looks like I'm now the one asking how to start the game 😂

0045:fixme:ntdll:EtwRegisterTraceGuidsA (0x669880f, 0x66d9a98, {0cfe0455-93ba-440d-a3fe-553973d0b723}, 1, 0x31e1f4, (null), (null), 0x66d9aa0): stub
0045:fixme:ntdll:EtwRegisterTraceGuidsA (0x669880f, 0x66d9ab8, {797fabac-7b58-4796-b924-d51178a59ce4}, 1, 0x31e1f4, (null), (null), 0x66d9ac0): stub
0045:fixme:ntdll:EtwEventRegister ({43d1a55c-76d6-4f7e-995c-64c711e5cafe}, 0x662a8a5, 0x66db318, 0x66db110) stub.
0045:fixme:shell:SHQueueUserWorkItem Unsupported arguments
0045:fixme:ras:RasEnumEntriesW (00000000,(null),072EBE78,0031E2F4,03EC08A4),stub!
004c:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
0045:fixme:ntdll:EtwEventActivityIdControl 0x1, 0x31e5ac: stub
0051:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
004d:fixme:shell:SHQueueUserWorkItem Unsupported arguments
004c:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
004d:fixme:ras:RasEnumEntriesW (00000000,(null),07300168,08D8FCD8,03C7B60C),stub!
004d:fixme:winsock:WSALookupServiceBeginW (0x8d8fd20 0x00000210 0x3ebfa50) Stub!
004d:fixme:shell:SHQueueUserWorkItem Unsupported arguments
004d:fixme:ras:RasEnumEntriesW (00000000,(null),07300168,08D8F980,03C7BEC4),stub!
004c:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
004d:fixme:shell:SHQueueUserWorkItem Unsupported arguments
004d:fixme:ras:RasEnumEntriesW (00000000,(null),07300168,08D8F74C,0175D95C),stub!
004c:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
004d:fixme:ntdll:server_ioctl_file Unsupported ioctl 9800012c (device=9800 access=0 func=4b method=0)
004d:fixme:winsock:server_ioctl_sock Unsupported ioctl 9800012c (device=9800 access=0 func=4b method=0)
004d:fixme:winsock:WSAIoctl unsupported WS_IOCTL cmd (SIO_SET_COMPATIBILITY_MODE)
004c:fixme:shell:SHQueueUserWorkItem Unsupported arguments
004c:fixme:ras:RasEnumEntriesW (00000000,(null),07300168,08C7FCD8,05D8AFBC),stub!
004d:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
004c:fixme:shell:SHQueueUserWorkItem Unsupported arguments
004c:fixme:ras:RasEnumEntriesW (00000000,(null),07300168,08C7FCD8,0129679C),stub!
004d:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
004c:fixme:shell:SHQueueUserWorkItem Unsupported arguments
004c:fixme:ras:RasEnumEntriesW (00000000,(null),07300168,08C7F74C,0175C4B4),stub!
004d:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
004c:fixme:ntdll:server_ioctl_file Unsupported ioctl 9800012c (device=9800 access=0 func=4b method=0)
004c:fixme:winsock:server_ioctl_sock Unsupported ioctl 9800012c (device=9800 access=0 func=4b method=0)
004c:fixme:winsock:WSAIoctl unsupported WS_IOCTL cmd (SIO_SET_COMPATIBILITY_MODE)
004d:fixme:shell:SHQueueUserWorkItem Unsupported arguments
004d:fixme:ras:RasEnumEntriesW (00000000,(null),07300168,08D8FCD8,016237FC),stub!
004c:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
004d:fixme:shell:SHQueueUserWorkItem Unsupported arguments
004c:fixme:ras:RasConnectionNotificationW (FFFFFFFF,00000160,0x00000003),stub!
004d:fixme:ras:RasEnumEntriesW (00000000,(null),07300168,08D8FCD8,01623ADC),stub!

 

Link to post
Share on other sites

Thanks, tried that again, and not going well

Created new wrapper

Opened wineskin inside it, used that gui to copy folder with the downloaded exe in it, and set it to run that exe

Ran the wrapper

Launches and wrapper icon shown in dock, but just stays there forever and nothing comes up on screen 😞

Link to post
Share on other sites
5 hours ago, hawthorneluke said:

Thanks, tried that again, and not going well

Created new wrapper

Opened wineskin inside it, used that gui to copy folder with the downloaded exe in it, and set it to run that exe

Ran the wrapper

Launches and wrapper icon shown in dock, but just stays there forever and nothing comes up on screen 😞

Hmmmmmmmmmmm I'll fuck with it on an OSX image later today. I know there's a way! lol Its just a matter of having the libraries included in your WINE environment. Also, this is 100x easier on Linux for some reason apparently. Cause in Ubuntu it kind of "just works" after you install WINE

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...